September 15, 2019, 16:33:17 PM

Post reply

Warning: this topic has not been posted in for at least 60 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.

Name:
Subject:
Message icon:

Verification:

shortcuts: hit alt+s to submit/post or alt+p to preview


Topic Summary

Posted by: Minister of Death
« on: October 30, 2016, 19:28:15 PM »

I understand your point, but I still think the priority should go to fixing the standard way first.
Posted by: Mariado45
« on: October 17, 2016, 04:01:06 AM »

Not to be rude, but a game this early in development hardly has an official way to play multiplayer reliably. Additionally, I recall the dev saying at one point that hamachi was a viable way to play multiplayer, but is not very experienced with it, as he showed surprise when he got told it was pretty bad.

I know it sounds very "entitled" to ask for a solution when using third party programs to host servers, but it's always a good idea to leave a possible solution when leaving criticism.

I'm very sure this was posted with the intent of getting help and not only getting told to do what I believe he has, probably, already tried.

Again, I hope this doesn't come off wrong to you. I just want to get to a nice outcome without misunderstandings.
Posted by: Minister of Death
« on: October 16, 2016, 06:23:29 AM »

You are using an unofficial way to play mutliplayer and expect a fix? I may seem mean, but you do know that you're asking a lot?
Especially considering that this game is in it's infancy. I'd give a try to the normal way first if I were in your stead, though I'm biased since I always had problems with hamachi whenever I used it, for every game I tried. It's not that complicated.
Posted by: gnarsies
« on: September 20, 2016, 04:52:15 AM »

Hello.
A friend and I are using Hamachi in attempt to play multiplayer, but as soon as we both ready up and the countdown for the game to start ends, the game either crashes if we play in 0.3, or kicks me out of the server with a pop up when we play in 0.4.2.


"21:27:01 INFO - UpdateLobbyNet: Starting in 3...
21:27:02 INFO - UpdateLobbyNet: Starting in 2...
21:27:03 INFO - UpdateLobbyNet: Starting in 1...
21:27:04 INFO - UpdateLobbyNet: Starting in 0...
21:27:04 INFO - UpdateLobbyNet: Send character data.
21:27:04 INFO - NM_TRANSFER: Received world data.
21:27:04 INFO - NM_TRANSFER: Loaded world data.
21:27:05 INFO - NM_TRANSFER: Loaded player data.
21:27:05 INFO - NM_TRANSFER: Level change to City Wardrock (id:1, level:0).
21:27:06 ERRO - Handling crash. Code: 0xc0000005
Text: Access violation
Flags: 0
Address: 0x00D10FAC.
21:27:06 INFO - Unhandled exception caught!
Code: 0xc0000005
Text: Access violation
Flags: 0
Address: 0x00D10FAC

Please report this error."


This happened along with an error about missing packet 20 from him. If I host, he can't connect to me, and if he hosts, he is able to enter the game, but I'm kicked out.
Thanks for your time.


EDIT - Redownloading the game and forwarding the port, we tried again, and this time this happened -
"18:16:02 INFO - UpdateLobbyNet: Starting in 3...
18:16:03 INFO - UpdateLobbyNet: Starting in 2...
18:16:04 INFO - UpdateLobbyNet: Starting in 1...
18:16:05 INFO - UpdateLobbyNet: Starting in 0...
18:16:05 INFO - UpdateLobbyNet: Waiting for server.
18:16:05 INFO - NM_TRANSFER: Received world data.
18:16:05 INFO - NM_TRANSFER: Loaded world data.
18:16:05 INFO - NM_TRANSFER: Loaded player start data.
18:16:06 INFO - NM_TRANSFER: Level change to City Neverock (id:3, level:0).
18:16:07 ERRO - Read level: Invalid building type 199.
18:16:07 ERRO - NM_TRANSFER: Failed to read location data.
18:16:07 INFO - Clear game and exit to menu.
18:16:07 INFO - Clearing game.
18:16:07 INFO - Leaving level.
18:16:07 INFO - Peer shutdown.
18:16:07 INFO - sv_online = false
18:16:07 INFO - Clearing game.
18:16:18 INFO - Game: Quit."
All of our problems are caused by invalid building types of various kinds.